Welcome, Guest. Please Login or Register
YaBB - Yet another Bulletin Board
  Latest info can be found on the YaBB Chat and Support Community.
  HomeHelpSearchLoginRegister  
 
Page Index Toggle Pages: 1
Send Topic Print
HX-150 Refrig Not Turning On (Read 2496 times)
i3 LLC
YaBB Newbies
*
Offline


Why didn't I change this?

Posts: 5
HX-150 Refrig Not Turning On
Sep 3rd, 2017 at 6:06pm
 
I purchased an HX-150 some about a year ago. Yesterday when I turned it on, it powered up:
The recirc pump turned on.
The stirring motor turned on.
The compressor and cooling fan did not turn on.
The Cool LED is on.
The Refrig LED is off.

It's like it's not even trying to turn the refrig. portion on.

What I have tried:
1. Checked all fuses (Two big fuses, four smaller fuses), all are fine.

2. Measured the resistance across the solenoid coil and measures 250ohms. The manual says it should be 750-850ohms.

3. Checked the voltage going to the solenoid with it connected and disconnected (measured at the connector where it connects to the control box). I get like ~3VAC. I assume it should be 240V if the controller is trying to turn it on.

4. Looked at the two large contactors in the control box near where the AC power enters. The contactor that turns the pump/stirrer on actuates. The contactor that engages the compressor/fan does not actuate.

Thoughts: The only actual thing I've seen off is the coil resistance. Does the controller look for the right coil resistance before deciding to go forward with powering up the refrig components? It seems like not a refrigeration problem, but a control problem, and maybe the solenoid figures into it.

Any thoughts would be appreciated.
Back to top
 
 
IP Logged
 
i3 LLC
YaBB Newbies
*
Offline


Why didn't I change this?

Posts: 5
Re: HX-150 Refrig Not Turning On
Reply #1 - Sep 5th, 2017 at 12:47pm
 
Replying to myself as an update...
Replaced Coil. New coil measured 825ohms.
Same behavior.

Removed two capacitors from box. One measures 100uf one measures 29uf. I assume that since they measure correctly that they are fine.

At a loss at what to do next.
Back to top
 
 
IP Logged
 
i3 LLC
YaBB Newbies
*
Offline


Why didn't I change this?

Posts: 5
Re: HX-150 Refrig Not Turning On
Reply #2 - Sep 5th, 2017 at 4:10pm
 
Probed each of three connections to the SSR in the capacitor box.
(AC Voltage with respect to ground).

System running, pump running.
Adjusted temp setting above and below water temp to go in and out of Cool mode, so it might try to engage refrig.

Refrig LED still never comes on, and voltages at the SSR don't change and stay at around 0V.
Back to top
 
 
IP Logged
 
i3 LLC
YaBB Newbies
*
Offline


Why didn't I change this?

Posts: 5
Re: HX-150 Refrig Not Turning On
Reply #3 - Sep 7th, 2017 at 9:09am
 
Since the system has no feedback mechanism like a pressure switch, my best guess at this point is that the problem lies in the relay logic on the pc board. There are a number of blue box relays there. Guessing one of them is bad. Will begin looking there.
Back to top
 
 
IP Logged
 
i3 LLC
YaBB Newbies
*
Offline


Why didn't I change this?

Posts: 5
Re: HX-150 Refrig Not Turning On
Reply #4 - Sep 7th, 2017 at 11:02pm
 
In tonight's saga...

Removed large Contactor nearest power entry. Cleaned all leads as most were corroded/oxidized. Tested contactor by applying 110V to coil. Works fine.
Removed Rear PC Board and applied 12VDC to input coils of blue relays. All relays worked.

Re-checked fuses.

Nothing has changed.
Back to top
 
 
IP Logged
 
Garciar
YaBB Newbies
*
Offline


Why didn't I change this?

Posts: 7
Re: HX-150 Refrig Not Turning On
Reply #5 - Sep 19th, 2017 at 11:44pm
 
more information
Back to top
 
 
IP Logged
 
Roman Erdmann
YaBB Newbies
*
Offline


Why didn't I change this?

Posts: 6
Re: HX-150 Refrig Not Turning On
Reply #6 - Oct 28th, 2017 at 12:09am
 
Thanks
Back to top
 
 
IP Logged
 
Adilah Bisar
YaBB Newbies
*
Offline


Why didn't I change this?

Posts: 6
Re: HX-150 Refrig Not Turning On
Reply #7 - Nov 8th, 2018 at 1:28am
 
ok
Back to top
 
 
IP Logged
 
BishopGilbert
YaBB Newbies
*
Offline


Why didn't I change this?

Posts: 8
Re: HX-150 Refrig Not Turning On
Reply #8 - Oct 13th, 2019 at 10:37am
 
Yeah, I've had problems with this HX-150 refrig, as well. I am sure that people who work at https://www.australianessays.org/assignment company will have experienced problems with this refrig, as well. It's not the best made.
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print